Supply Chain Demo failed to login


#1

Hi,

I have my API and my UI servers running.

The Blockchain enabled SCM page displays just fine.

I have checked my Strato Dashboard and the Users and Contracts are all displayed.

But when I try and login with Buyer1 and Password 1234 it displays;

“failed to Fetch” message at the bottom.

The Node is running on an Azure Strato VM and I have ports 3030 and 3031 open. I also have a fixed Public IP.

What is the problem?

Regards

Synaptoman


#2

Hi @Synaptoman - can you run docker logs strato_bloc_1 and attach the result?


#3


#4

If I run

sudo docker logs strato_bloc_1

I get;

No such container


#5

So I tried

sudo docker ps and strato_bloc_1 wasn’t listed. I am assuming this is run on the Strato Node (Azure)?

Here is the list.


#6

On my Google Cloud Services node strato_bloc_1 does exist and the log ends with;

“All processes are healthy”


#7

@Synaptoman - thanks. Can you also run stradmin_bloc_1 and post the result?


#8

Hi,

On the Azure node above there is only a;

stradmin_bloch_1 with an “h”

Sure looks like a typo to me.

Is that the one you want?

Regards


#9

That’s correct @Synaptoman, it’s stradmin_bloch_1 with an “h”. Please excuse the typo.


#10

image


#11

Hi @Synaptoman - we should be able to resolve this quickly if you allow us to access to the VM via SSH.

To do this you will need to add our public key to the authorized SSH clients list:

  1. SSH to machine
  2. Run:
    echo "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC3EAP2j9+Cj8DxdFAqgWryNrfNZqDcXlepVDSDnuoRul21FEN5FHsj/6kGcln9BFT9zSzkfqTqAM/d8M/AmY2v4UE4zZWdtJgpwuZHZ23XjT3SbvW+Sq6fhbaP82afGIHnloubZ/128A7QUCZaNfxIf+uXMFGbZ91gg9WkPI8CWBVq0H1P1TxnE2QLntuh9xJ5Y5HsJjnRFxpcqzTrJPhJcgkh2LJSJbL5JffRFzIzHxE7zj5eDkv2dykZdVvkikGDgT967Xfy3BLSieis/fq7Hhsk1PjVQU4oZcHVHsg87Yrzj4S3chxXDG0sYnpU2TE40G0UYHZntJa4rXtLivfz" >> ~/.ssh/authorized_keys
  3. Reply (or DM me) the username and the IP of the virtual machine (like [email protected])

Otherwise we can set up a call to resolve this in real time.