Invalid interpolation format for “environment” option in service “strato” "validators=${validators:>"


#1

hi
i am facing Invalid interpolation format for “environment” option in service “strato” “validators=${validators:>” error when i try to start the service.

any solution for it ?


#2

Hi sengkok,

Can you please include more details about how you are starting up strato? This looks like a template bug, and it would be helpful to know which template to look at.


#3

Thank you for reaching us out.
The options here are:

  1. Update docker-compose utility to latest version
  2. Edit the docker-compose.yml line:
    - validators=${validators:-}
    to be:
    - validators=${validators}

The compatibility with older docker-compose will be fixed in the next STRATO release.


#4

Thanks, it is great help. After i start the service successfully but i cant browse the dashboard in localhost.
any solution for this ?


#5

Please check the output of docker exec -it strato_strato_1 tail /var/lib/strato/logs/ethereum-vm (STRATO v4.2 - your case) or docker exec -it strato_strato_1 tail /var/lib/strato/logs/vm-runner (STRATO v4.3 or later) to see the error message.
In most of the cases the wipe and restart of the node should help. But please post the error message here first so we could investigate.

Best,
Nikita


#6

[email protected]:~/strato-getting-started$ docker exec -it strato_strato_1 tail /var/lib/strato/logs/ethereum-vm
[2019-03-12 04:16:13.061157604 UTC] INFO | ThreadId 5 | evm/loop/newBlock | Num poolable: 0, num pending: 0
[2019-03-12 04:16:13.061248771 UTC] INFO | ThreadId 5 | evm/loop/newBlock | Decision making for block creation: (isCaughtUp, pbft, reqd, hasTxs, makeLazyBlocks, shouldOutputBlocks) = (True,True,True,False,False,False)
[2019-03-12 04:16:13.061377703 UTC] INFO | ThreadId 5 | timeit | #### flushLogEntries time = 0.0000s
[2019-03-12 04:16:13.06153323 UTC] INFO | ThreadId 5 | timeit | #### flushTransactionResults time = 0.0000s
[2019-03-12 04:16:13.061676123 UTC] INFO | ThreadId 5 | timeit | #### writeActionJSONToKafka time = 0.0000s
[2019-03-12 04:16:13.061805963 UTC] INFO | ThreadId 5 | setCheckpoint | Setting checkpoint to Offset 22 / EVMCheckpoint 22ac7a27382e1097
[2019-03-12 04:16:13.08028836 UTC] INFO | ThreadId 5 | timeit | #### one full loop time = 10.0875s
[2019-03-12 04:16:13.080603395 UTC] INFO | ThreadId 5 | getCheckpointNoMetadata | Getting checkpoint for TopicName “seq_vm_events”#0 for ConsumerGroup (KString {_kString = “ethereum-vm_6a0e565c90eb2d5f8145f7e00bb764ab653d33c8”})
[2019-03-12 04:16:13.083330995 UTC] INFO | ThreadId 5 | evm/loop | Getting Blocks/Txs
[2019-03-12 04:16:13.083507185 UTC] INFO | ThreadId 5 | getUnprocessedKafkaEvents | Fetching sequenced blockchain events with offset Offset 22


#7

Hi Nikita,

I’m facing the same issue too but with different error log.

[email protected]:~/strato-getting-started$ docker exec -it strato_strato_1 tail /var/lib/strato/logs/vm-runner

  • proc_pid=107
  • MONITORED_PIDS[${proc_pid}]=‘vm-runner --useSyncMode=false --miner=Instant --maxTxsPerBlock=500 --diffPublish=true --sqlDiff=true --createTransactionResults=true --miningVerification=false --difficultyBomb=false --trace=false --debug=false --minLogLevel=LevelInfo --blockstanbul=true +RTS -N1’
  • echo ‘process pid:: 107 (command: vm-runner’ --useSyncMode=false --miner=Instant --maxTxsPerBlock=500 --diffPublish=true --sqlDiff=true --createTransactionResults=true --miningVerification=false --difficultyBomb=false --trace=false --debug=false --minLogLevel=LevelInfo --blockstanbul=true +RTS ‘’ ‘-N1)’
    process pid:: 107 (command: vm-runner --useSyncMode=false --miner=Instant --maxTxsPerBlock=500 --diffPublish=true --sqlDiff=true --createTransactionResults=true --miningVerification=false --difficultyBomb=false --trace=false --debug=false --minLogLevel=LevelInfo --blockstanbul=true +RTS -N1)
  • disown %
  • vm-runner --useSyncMode=false --miner=Instant --maxTxsPerBlock=500 --diffPublish=true --sqlDiff=true --createTransactionResults=true --miningVerification=false --difficultyBomb=false --trace=false --debug=false --minLogLevel=LevelInfo --blockstanbul=true +RTS -N1

#8

Hi mktan,

Can we take a look at the full log files? See Unable launch Strato management Dashboard localhost for the script.

If not, docker logs strato_strato_1 will point to the unhealthy process and the logs in /var/lib/strato/logs/<process_name> will explain why that process crashed.