Installation and Deployment on Windows fails


#1

In Docker terminal I issue the following:
NODE_HOST=192.168.99.100 ./strato.sh --single

and receive the following:

   / __ )/ /___  _____/ /__/   |  ____  ____  _____
  / __  / / __ \/ ___/ //_/ /| | / __ \/ __ \/ ___/
 / /_/ / / /_/ / /__/ ,< / ___ |/ /_/ / /_/ (__  )
/_____/_/\____/\___/_/|_/_/  |_/ .___/ .___/____/
                              /_/   /_/


*** Common Config ***
NODE_HOST: 192.168.99.100
ssl: false
sslCertFileType: crt
NODE_NAME: 192.168.99.100
BLOC_URL: http://192.168.99.100/bloc/v2.2
BLOC_DOC_URL: http://192.168.99.100/docs/?url=/bloc/v2.2/swagger.json
STRATO_URL: http://192.168.99.100/strato-api/eth/v1.2
STRATO_DOC_URL: http://192.168.99.100/docs/?url=/strato-api/eth/v1.2/swagger.json
CIRRUS_URL: http://192.168.99.100/cirrus/search
APEX_URL: http://192.168.99.100/apex-api
authBasic: true
uiPassword: not set (using default)
STRATO_GS_MODE: 0
SMD_MODE: enterprise
EXT_STORAGE_S3_BUCKET: not set
EXT_STORAGE_S3_ACCESS_KEY_ID: not set
EXT_STORAGE_S3_SECRET_ACCESS_KEY: not set

Running single node with lazy mining
*** Single-node Config ***
SINGLE_MODE: true

*** Genesis Block ***
Genesis block is not set (using default)
Downloading the latest stable version of docker-compose.yml
./strato.sh: line 62: wget: command not found

Please advise on how to fix.

Thank you


#2

You need to install wget:

http://gnuwin32.sourceforge.net/packages/wget.htm

or

npm install wget


#3

Thank you. I had wget installed just not on my PATH. This solved my issue.