Install failing to pull Postgresql


#1

When I try to run the getting started example you have on http://developers.blockapps.net/install/local/ I get the following error.

Pulling postgres-cirrus (postgres:9.6)…
ERROR: Get https://registry-1.docker.io/v2/library/postgres/manifests/9.6: unauthorized: incorrect username or password

I use the username and password you sent me to start itdocker login -u username -p password registry-aws.blockapps.net:5000

What can I do to fix this?


#2

It seems that there was some maintenance of the Docker registry. Yesterday I was not able to “docker login”, was getting I/O timeouts. Now it works fine.


#3

Hi,

Getting same error today. ERROR: Get https://registry-1.docker.io/v2/library/postgres/manifests/9.6: unauthorized: incorrect username or password

Is there something happening with repository today?


#4

The username and password we sent you are only used to access our BlockApps registry which is registry-aws.blockapps.net:5000.
However postgres:9.6 is a public image which is supposed to be pulled from Docker public registry with docker out-of-the-box.
If you can replicate this issue with docker pull postgres:9.6 command then you should refer to Docker forums or support.
To start with, please confirm you don’t have any additional configurations in the auth object of ~/.docker/config.json file except our registry.


#5

When I login to docker and pull postgres using docker pull postgres:9.6 it works fine.