Error when running ./strato-run.sh (docker-compose.release.yml issue)


#1

Using the latest version of Strato, when I try to stop Strato using the command: “./strato-run-.sh --stop” or “./strato-run.sh --wipe”, I receive the following error:

Stopping STRATO containers
ERROR: Top level object in ‘./docker-compose.release.yml’ needs to be an object not ‘<type ‘NoneType’>’.

Has anyone seen this error before or know the cause? I have no problems getting Starto to start, but just not able to wipe the containers.

Very much appreciated,

Sam


#2

Hi.
Please, provide the output for:

docker version
docker-compose version

and make sure the docker-compose.release.yml file content is an actual YML and not something else (like the empty file or the curl response error output etc.)
You may remove this file and fetch it again with command:

curl -s -L https://github.com/blockapps/strato-getting-started/releases/latest | egrep -o '/blockapps/strato-getting-started/releases/download/build-[0-9]*/docker-compose.release.yml'

or just save the file from web: https://github.com/blockapps/strato-getting-started/releases/download/build-49/docker-compose.release.yml


#3

Thank you.

Docker version output:

 Client:
 Version:      1.13.1
 API version:  1.26
 Go version:   go1.8.3
 Git commit:   092cba3
 Built:        Thu Oct 12 22:34:44 2017
 OS/Arch:      linux/amd64

Server:
 Version:      1.13.1
 API version:  1.26 (minimum version 1.12)
 Go version:   go1.8.3
 Git commit:   092cba3
 Built:        Thu Oct 12 22:34:44 2017
 OS/Arch:      linux/amd64
 Experimental: false

Docker-Compose Version output:

docker-compose version 1.18.0, build 8dd22a9
docker-py version: 2.6.1
CPython version: 2.7.13
OpenSSL version: OpenSSL 1.0.1t  3 May 2016

Are these versions compatible?

I have used the .yml file you’ve directed me to, and with that .YML file I receive a different error:

WARNING: The useSyncMode variable is not set. Defaulting to a blank string.
WARNING: The evmDebugMode variable is not set. Defaulting to a blank string.
WARNING: The numMinPeers variable is not set. Defaulting to a blank string.
WARNING: The NODE_HOST variable is not set. Defaulting to a blank string.
WARNING: The authBasic variable is not set. Defaulting to a blank string.
WARNING: The uiPassword variable is not set. Defaulting to a blank string.
WARNING: The stateDiffTopic variable is not set. Defaulting to a blank string.
Killing strato_nginx_1 ... 

ERROR: for strato_nginx_1  UnixHTTPConnectionPool(host='localhost', port=None): Read timed out. (read timeout=60)
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).

Thank you again Nikita, much appreciated.