Error: Applet not found


#1

When I tried to install and setup ‘STRATO Developer Edition using Docker’ by following the instructions on page: https://developers.blockapps.net/install/local/ I got stuck on step:

  1. Launch STRATO services:
    Then run the script (runs latest STRATO version by default): bash ./strato-run.sh or to run stable version: bash ./strato-run.sh --stable

If I execute command: bash ./strato-run.sh, I get error: env:can’t execute ‘bash’ : No such file or directory.
After googling for a while I found out that I should use busybox. But if I run command busybox ./stato-run.sh, I get another error: strato-run.sh: applet not found.

Could you tell me how can I fix these problems.


#2

Hi @mare148!
Thanks for letting us know. We fixed the docs at https://developers.blockapps.net/install/local/ removing the bash from the command.
Still, please make sure you run STRATO Developer Edition in Linux/Macos terminal or using Docker Toolbox (not “Docker for Windows”) on Windows.
You don’t need busybox to run STRATO.

[email protected]


#3

Thank you for your answer.

I am using Docker Toolbox downloaded from page: https://www.docker.com/products/docker-toolbox, but I still get error env: can’t execute ‘bash’ : No such file or directory when executing command: ./strato-run.sh.


#4

bash command should be available in Docker Toolbox out-of-the-box.
Please make sure you run it in Docker Toolbox terminal window, not CMD or PowerShell. If the error remains - please contact Docker support.
We would appreciate any additional information which can help us solve this kind of issue in the future.


#6

Actually @mare148, the docker toolbox is running a linux VM so you don’t need the bash command at all. Just write everything AFTER the bash keyword and it should run just fine. As an aside, if you are running from docker toolbox, your strato run will no longer be on localhost and you should navigate to 192.168.99.100 to access the dashboard. Furthermore, use this command when starting up from that docker toolbox:

DOMAIN_NAME=$(docker-machine ip default) ./strato-run.sh