Dashboard not displaying on Azure


#1

I was having issues with creating users/accounts on my Strato private blockchain on Azure (posting account was successful but accounts were not showing in the dashboard).

Eventually I wiped everything by issuing the

./strato-run.sh -wipe

command.

And reran strato.

Although I do not get an error on restarting, the Dashboard fails to display (cannot connect).
Any suggestions on what to try?
Thanks.


#2

Hi @pheneghan

Thanks for trying STRATO on Azure and reaching out here about this.
We’ve hit this issue of “accounts not showing in the dashboard immediately after creating” before and it’s fixed in our latest release build here: https://developers.blockapps.net/install/local/
Azure marketplace image update is in progress (taking longer due to some more Azure specific changes that are in review) so should be there soon.

From what you described after the “reran strato” procedure it seems that STRATO Management Dashboard (SMD) didn’t start with the correct node (HOST) URL.
Were you able to run strato-run.sh passing in the “FQDN or public-IP of the machine” as command-line arg?

The steps to do that are documented here:
https://developers.blockapps.net/install/azure/

If this doesn’t work, can you share the details of the Azure marketplace offer (link) that you are trying?
I’m guessing you’re trying this offer: https://azuremarketplace.microsoft.com/en-us/marketplace/apps/blockapps.strato-blockchain-lts-vm?tab=Overview

Let us know how this works out, happy to triage and help further.

Best,
Kishore


#3

Hi Kishore
Thanks for the prompt reply. Yes I restarted using strato-run.sh with the public IP. There were no errors but the dashboard would not display. I restarted the virtual machine on Azure and re-ran strato-run.sh with the correct IP address. I did this a couple of times and briefly the dashboard DID display (yes, I have been using the correct node/host IP the whole time). However the dashboard “health” symbol showed the yellow warning symbol. I tried re-running strato-run.sh with IP address again but got the same result. After about 10 minutes the dashboard is failing to display once again.
Thanks in advance for any suggestions.


#4

Hi! @pheneghan I had same setup issue when I tried to setup my virtual environment in Azure cloud so I created a document with steps that weren’t mentioned in https://developers.blockapps.net/install/azure/ to help me when setting up my Strato instance in Azure.

You can read the instructions at below link and follow them precisely:
Strato-Azure-Setup

Let me know if you’re successful in setting it up.


#5

Hi @suchit - thanks for this documentation. The difference between what I did in setup and what you have documented is:

  1. I used a password for authentication rather than SSH public key.
  2. I did not assign a static DNS name but issued the startup command as ./start-run.sh [IP Address].

Do you think both of these steps are necessary to ensure success (use SSH AND use DNS name)?
Thanks again


#6

@pheneghan those two step are important. You do need static ip and SSH public key. You can follow this link to setup your SSH.

Create SSH Key

Also you might have it already setup by default. In order to read your public key you can give following commands on your terminal:

cat ~/.ssh/id_rsa.pub