Can not start strato. ERROR: for nginx


#1

Hi
After I run “./strato-run.sh”, I got this print:

Creating strato_nginx_1 …

ERROR: for strato_nginx_1 UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)

ERROR: for nginx UnixHTTPConnectionPool(host=‘localhost’, port=None): Read timed out. (read timeout=60)
ERROR: An HTTP request took too long to complete. Retry with --verbose to obtain debug information.
If you encounter this issue regularly because of slow network conditions, consider setting COMPOSE_HTTP_TIMEOUT to a higher value (current value: 60).
[email protected]:~/strato/strato_start/strato-getting-started-master# ps ax|grep nginx
7025 ? Ss 0:00 nginx: master process nginx -g daemon off;
7293 ? S 0:00 nginx: worker process
11350 pts/0 D+ 0:00 grep --color=auto nginx

It seems strato server failed to start nginx in this process. If I visit “localhost” on browser I got “Unable to connect” page.

My OS info: Ubuntu 16.04 64bit

Docker version:
Client:
Version: 17.06.2-ee-6
API version: 1.30
Go version: go1.8.3
Git commit: e75fdb8
Built: Mon Nov 27 22:45:33 2017
OS/Arch: linux/amd64

Server:
Version: 17.06.2-ee-6
API version: 1.30 (minimum version 1.12)
Go version: go1.8.3
Git commit: e75fdb8
Built: Mon Nov 27 22:44:25 2017
OS/Arch: linux/amd64
Experimental: false

Please help, thinks!


#2

Hi @luchaoxx,
Can you please make sure that the following ports are open and try again?
:80, :443 (for Nginx)
:30303, :30303/UDP (for Strato P2P)

Please run: ./strato-run.sh --wipe
After this please run: ./strato-run.sh --stable


#3

Hi @Jason,
I can start strato with “–stable” type after run “–wipe”.
However, I still can not open managerment dashboard. The page is error on “ERR_CONNECTION_REFUSED”.
I saw nginx process as below:

ps ax|grep nginx

7796 ? Ss 0:00 nginx: master process nginx -g daemon off;
7967 ? S 0:00 nginx: worker process
12550 pts/0 S+ 0:00 grep --color=auto nginx

and port 80 was used by this process. But, when I telent port 80, it said:

telnet 127.0.0.1 80

Trying 127.0.0.1…
Connected to 127.0.0.1.
Escape character is ‘^]’.
Connection closed by foreign host.

I am sure port 80 is open and ufw is disabled, I used to started nginx alone and visit “Welcome to nginx” page, it is OK.