Azure Installation fail: strato-run .sh: No such file or directory


#1

Followed instructions for Azure STRATO Blockchain Singlenode - Developer Edition install from “developers.blockapps.net/install/azure/

When using Putty to SSH into IP, I try to run strato-run.sh and receive the following:

-bash: ./strato-run.sh: No such file or directory

Tried it as admin strato and stradmin without difference. Was able to run TEST DRIVE successfully and am now ready to dig in deeper.

Please advise.


#2

Hi @joeho,

Can you try:
./strato-run.sh (FQDN of the machine)

where FQDN is the fully qualified DNS domain name of your machine, don’t include the brackets.

e.g.
$ ./strato-run.sh strato-mp-instance.eastus.cloudapp.azure.com


#3

I have been using the FQDN in command. Created a new deployment just now and here is copy from Putty window

[email protected]:~$ ./strato-run.sh trialsr2mp.eastus.cloudapp.azure.com
-bash: ./strato-run.sh: No such file or directory


#4

Hello, any update on this issue? Should I just try a manual setup using the VM generated by the template?


#5

I ran the same package as you and my STRATO instance was already running when my VM came up.
Can you test by navigating to http://[your server ip]?


#6

Yes, tried that all along without being able to login and just got it working now. I finally guessed I needed to use “admin” user name instead of strato admin name I defined at template start up.

Thanks.


#7

Thank you for the follow-up. We updated our documentation accordingly: https://developers.blockapps.net/install/azure/


#8

Good to hear! Thanks for the follow up @joeho.